#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?sm)(第.*?条)\n(?:.*?)(\d+)\n([^\s]+)"
Local $sString = "第四百六十三条" & @CRLF & _
"【条文主旨】17" & @CRLF & _
"本条是关于合同编调整对象的规定。" & @CRLF & _
"第四百六十四条" & @CRLF & _
"【条文主旨】23" & @CRLF & _
"本条是关于合同的概念及适用的规定。"
Local $sSubst = "$1\n【$3】$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)