use strict;
my $str = '第四百六十三条
【条文主旨】17
本条是关于合同编调整对象的规定。
第四百六十四条
【条文主旨】23
本条是关于合同的概念及适用的规定。';
my $regex = qr/(第.*?条)\n(?:.*?)(\d+)\n([^\s]+)/smp;
my $subst = '$1\\n【$3】$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";