using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(第.*?条)\n(?:.*?)(\d+)\n([^\s]+)";
string substitution = @"$1\n【$3】$2";
string input = @"第四百六十三条
【条文主旨】17
本条是关于合同编调整对象的规定。
第四百六十四条
【条文主旨】23
本条是关于合同的概念及适用的规定。";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}