$re = '/(第.*?条)\n(?:.*?)(\d+)\n([^\s]+)/sm';
$str = '第四百六十三条
【条文主旨】17
本条是关于合同编调整对象的规定。
第四百六十四条
【条文主旨】23
本条是关于合同的概念及适用的规定。';
$subst = "$1\n【$3】$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;