# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(第.*?条)\n(?:.*?)(\d+)\n([^\s]+)"
test_str = ("第四百六十三条\n"
"【条文主旨】17\n"
"本条是关于合同编调整对象的规定。\n"
"第四百六十四条\n"
"【条文主旨】23\n"
"本条是关于合同的概念及适用的规定。")
subst = "$1\\n【$3】$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.