package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)(第.*?条)\n(?:.*?)(\d+)\n([^\s]+)`)
var str = `第四百六十三条
【条文主旨】17
本条是关于合同编调整对象的规定。
第四百六十四条
【条文主旨】23
本条是关于合同的概念及适用的规定。`
var substitution = "$1\n【$3】$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}