# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^a-zA-Z]*)([a-z])|(\.\s*)([a-z])/$1\U$2$3\U$4/gm;t' <<< ".this sentence
and this
This is already
.this sentence
and this.also this. and this.This one is not."