import Foundation
let pattern = #"^([^a-zA-Z]*)([a-z])|(\.\s*)([a-z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.this sentence
and this
This is already
.this sentence
and this.also this. and this.This one is not.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\U$2$3\U$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)