re = /^([^a-zA-Z]*)([a-z])|(\.\s*)([a-z])/m
str = '.this sentence
and this
This is already
.this sentence
and this.also this. and this.This one is not.'
subst = '$1\\U$2$3\\U$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result