#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^a-zA-Z]*)([a-z])|(\.\s*)([a-z])"
Local $sString = ".this sentence" & @CRLF & _
"and this" & @CRLF & _
"This is already" & @CRLF & _
".this sentence" & @CRLF & _
"and this.also this. and this.This one is not."
Local $sSubst = "$1\U$2$3\U$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)