use strict;
my $str = '.this sentence
and this
This is already
.this sentence
and this.also this. and this.This one is not.';
my $regex = qr/^([^a-zA-Z]*)([a-z])|(\.\s*)([a-z])/mp;
my $subst = '$1\\U$2$3\\U$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";