# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([,;:"'\\\s])es1\b|\bes1([,;:"',\\\s])/${1}es4$2/gm;t' <<< ":es1
es2
aaes1aa
:es3,
es1:
ees1,
ees1
{
\"es1 :"