const regex = new RegExp('([,;:"\\'\\\\\\s])es1\\b|\\bes1([,;:"\\',\\\\\\s])', 'gm')
const str = `:es1
es2
aaes1aa
:es3,
es1:
ees1,
ees1
{
"es1 :`;
const subst = `${1}es4$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);