$re = '`([,;:"\'\\\\\s])es1\b|\bes1([,;:"\',\\\\\s])`m';
$str = ':es1
es2
aaes1aa
:es3,
es1:
ees1,
ees1
{
"es1 :';
$subst = "${1}es4$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;