package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([,;:"'\\\s])es1\b|\bes1([,;:"',\\\s])`)
var str = `:es1
es2
aaes1aa
:es3,
es1:
ees1,
ees1
{
"es1 :`
var substitution = "${1}es4$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}