#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([,;:"'\\\s])es1\b|\bes1([,;:"',\\\s])"
Local $sString = ":es1" & @CRLF & _
"es2" & @CRLF & _
"aaes1aa" & @CRLF & _
":es3," & @CRLF & _
"es1:" & @CRLF & _
"ees1," & @CRLF & _
"ees1 " & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
""es1 :"
Local $sSubst = "${1}es4$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)