use strict;
my $str = ':es1
es2
aaes1aa
:es3,
es1:
ees1,
ees1
{
"es1 :';
my $regex = qr`([,;:"'\\\s])es1\b|\bes1([,;:"',\\\s])`mp;
my $subst = '${1}es4$2';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";