using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([,;:""'\\\s])es1\b|\bes1([,;:""',\\\s])";
string substitution = @"${1}es4$2";
string input = @":es1
es2
aaes1aa
:es3,
es1:
ees1,
ees1
{
""es1 :";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}