import Foundation
let pattern = #"([,;:"'\\\s])es1\b|\bes1([,;:"',\\\s])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
:es1
es2
aaes1aa
:es3,
es1:
ees1,
ees1
{
"es1 :
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${1}es4$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)