# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^,]*,[^,]*),/2/;t' <<< "<190>May 4 20:20:36 data.test.com 1,2023/05/04 20:20:35,013001101002958,TRAFFIC,end,2305,2023/05/04 "