package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^,]*,[^,]*),`)
var str = []byte(`<190>May 4 20:20:36 data.test.com 1,2023/05/04 20:20:35,013001101002958,TRAFFIC,end,2305,2023/05/04 `)
var substitution = []byte("2")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}