import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^,]*,[^,]*),";
final String string = "<190>May 4 20:20:36 data.test.com 1,2023/05/04 20:20:35,013001101002958,TRAFFIC,end,2305,2023/05/04 ";
final String subst = "2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}