$re = '/^([^,]*,[^,]*),/';
$str = '<190>May 4 20:20:36 data.test.com 1,2023/05/04 20:20:35,013001101002958,TRAFFIC,end,2305,2023/05/04 ';
$subst = "2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;