use strict;
my $str = '<190>May 4 20:20:36 data.test.com 1,2023/05/04 20:20:35,013001101002958,TRAFFIC,end,2305,2023/05/04 ';
my $regex = qr/^([^,]*,[^,]*),/p;
my $subst = '2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";