import re
regex = re.compile(r"^([^,]*,[^,]*),")
test_str = "<190>May 4 20:20:36 data.test.com 1,2023/05/04 20:20:35,013001101002958,TRAFFIC,end,2305,2023/05/04 "
subst = "2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)