import Foundation
let pattern = #"^([^,]*,[^,]*),"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<190>May 4 20:20:36 data.test.com 1,2023/05/04 20:20:35,013001101002958,TRAFFIC,end,2305,2023/05/04 "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}