using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^,]*,[^,]*),";
string substitution = @"2";
string input = @"<190>May 4 20:20:36 data.test.com 1,2023/05/04 20:20:35,013001101002958,TRAFFIC,end,2305,2023/05/04 ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}