const regex = /(?<=")\p{Ll}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=")\\p{Ll}', 'gm')
const str = `list: ["required","TBD at time of entry", "respirator, gloves, coveralls, etc."]`;
const subst = `\U$0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);