use strict;
my $str = 'list: ["required","TBD at time of entry", "respirator, gloves, coveralls, etc."]';
my $regex = qr/(?<=")\p{Ll}/mp;
my $subst = '\\U$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";