re = /(?<=")\p{Ll}/m
str = 'list: ["required","TBD at time of entry", "respirator, gloves, coveralls, etc."]'
subst = '\\U$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result