#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*\d+(?:\.\d+)?$"
Local $sString = "2.34 567 67.89" & @CRLF & _
"Text 2. More text 4.555. And 45"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)