using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*\d+(?:\.\d+)?$";
string substitution = @"";
string input = @"2.34 567 67.89
Text 2. More text 4.555. And 45";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}