const regex = /\s*\d+(?:\.\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*\\d+(?:\\.\\d+)?$', 'gm')
const str = `2.34 567 67.89
Text 2. More text 4.555. And 45`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);