$re = '/\s*\d+(?:\.\d+)?$/m';
$str = '2.34 567 67.89
Text 2. More text 4.555. And 45';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;