use strict;
my $str = '/page/
/page/2
kartinki/page/
kartinki/page/4';
my $regex = qr/page\//p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";