#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(\\s|[\"\'\\([{]|^)id\s?((?:[1-9]|10)\.(?:[1-9]|[1-9][0-9]|100))(["':.;,!?…\]})]|\s|$)"
Local $sString = "id1.1" & @CRLF & _
"id1.10" & @CRLF & _
"id10.100" & @CRLF & _
"id10.1" & @CRLF & _
"id 1.1" & @CRLF & _
"# The following should not match" & @CRLF & _
"id0.1" & @CRLF & _
"id1.0" & @CRLF & _
"id11.1" & @CRLF & _
"id1.200" & @CRLF & _
"id1.101" & @CRLF & _
"id1.1000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")