package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(\\s|[\"\'\\([{]|^)id\s?((?:[1-9]|10)\.(?:[1-9]|[1-9][0-9]|100))(["':.;,!?…\]})]|\s|$)`)
var str = `id1.1
id1.10
id10.100
id10.1
id 1.1
# The following should not match
id0.1
id1.0
id11.1
id1.200
id1.101
id1.1000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}