using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\s|[\""\'\\([{]|^)id\s?((?:[1-9]|10)\.(?:[1-9]|[1-9][0-9]|100))([""':.;,!?…\]})]|\s|$)";
string input = @"id1.1
id1.10
id10.100
id10.1
id 1.1
# The following should not match
id0.1
id1.0
id11.1
id1.200
id1.101
id1.1000";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}