import re
regex = re.compile(r"(\\s|[\"\'\\([{]|^)id\s?((?:[1-9]|10)\.(?:[1-9]|[1-9][0-9]|100))([\"':.;,!?…\]})]|\s|$)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("id1.1\n"
"id1.10\n"
"id10.100\n"
"id10.1\n"
"id 1.1\n"
"# The following should not match\n"
"id0.1\n"
"id1.0\n"
"id11.1\n"
"id1.200\n"
"id1.101\n"
"id1.1000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")