import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\s|[\\\"\\'\\\\([\\{]|^)id\\s?((?:[1-9]|10)\\.(?:[1-9]|[1-9][0-9]|100))([\"':.;,!?…\\]\\})]|\\s|$)";
final String string = "id1.1\n"
+ "id1.10\n"
+ "id10.100\n"
+ "id10.1\n"
+ "id 1.1\n"
+ "# The following should not match\n"
+ "id0.1\n"
+ "id1.0\n"
+ "id11.1\n"
+ "id1.200\n"
+ "id1.101\n"
+ "id1.1000";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}