use strict;
my $str = 'id1.1
id1.10
id10.100
id10.1
id 1.1
# The following should not match
id0.1
id1.0
id11.1
id1.200
id1.101
id1.1000';
my $regex = qr/(\\s|[\"\'\\([{]|^)id\s?((?:[1-9]|10)\.(?:[1-9]|[1-9][0-9]|100))(["':.;,!?…\]})]|\s|$)/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}