const regex = /(\\s|[\"\'\\([{]|^)id\s?((?:[1-9]|10)\.(?:[1-9]|[1-9][0-9]|100))(["':.;,!?…\]})]|\s|$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\\s|[\\"\\\'\\\\([{]|^)id\\s?((?:[1-9]|10)\\.(?:[1-9]|[1-9][0-9]|100))(["\':.;,!?…\\]})]|\\s|$)', 'gim')
const str = `id1.1
id1.10
id10.100
id10.1
id 1.1
# The following should not match
id0.1
id1.0
id11.1
id1.200
id1.101
id1.1000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}