// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)(\\s|[\"\'\\([{]|^)id\s?((?:[1-9]|10)\.(?:[1-9]|[1-9][0-9]|100))(["':.;,!?…\]})]|\s|$)"#).unwrap();
let string = "id1.1
id1.10
id10.100
id10.1
id 1.1
# The following should not match
id0.1
id1.0
id11.1
id1.200
id1.101
id1.1000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}