using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*[^-])\s(\d.*)$";
string input = @"Friedr 5 ichstr 4
Friedrichstr. 44
Friedrichstr. 4a
Friedrichstr. 4A
Friedrichstr. 44a
Friedrichstr. 423B
Friedrichstr. 4a-5
Friedrichstr. 4-5A
Friedrichstr. 4 - 5
Friedrichstr. 4A - 34B
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}