import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*[^-])\\s(\\d.*)$";
final String string = "Friedr 5 ichstr 4\n"
+ "Friedrichstr. 44\n"
+ "Friedrichstr. 4a\n"
+ "Friedrichstr. 4A\n"
+ "Friedrichstr. 44a\n"
+ "Friedrichstr. 423B\n"
+ "Friedrichstr. 4a-5\n"
+ "Friedrichstr. 4-5A\n"
+ "Friedrichstr. 4 - 5\n"
+ "Friedrichstr. 4A - 34B\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}