import Foundation
let pattern = #"^(.*[^-])\s(\d.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Friedr 5 ichstr 4
Friedrichstr. 44
Friedrichstr. 4a
Friedrichstr. 4A
Friedrichstr. 44a
Friedrichstr. 423B
Friedrichstr. 4a-5
Friedrichstr. 4-5A
Friedrichstr. 4 - 5
Friedrichstr. 4A - 34B
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)