re = /^(.*[^-])\s(\d.*)$/m
str = 'Friedr 5 ichstr 4
Friedrichstr. 44
Friedrichstr. 4a
Friedrichstr. 4A
Friedrichstr. 44a
Friedrichstr. 423B
Friedrichstr. 4a-5
Friedrichstr. 4-5A
Friedrichstr. 4 - 5
Friedrichstr. 4A - 34B
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end