package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*[^-])\s(\d.*)$`)
var str = `Friedr 5 ichstr 4
Friedrichstr. 44
Friedrichstr. 4a
Friedrichstr. 4A
Friedrichstr. 44a
Friedrichstr. 423B
Friedrichstr. 4a-5
Friedrichstr. 4-5A
Friedrichstr. 4 - 5
Friedrichstr. 4A - 34B
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}