#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""courselectureid":(\d+)"
Local $sString = ""1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429" & @CRLF & _
""1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429" & @CRLF & _
""1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429" & @CRLF & _
""1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429" & @CRLF & _
""1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4","metainfoid":877,"courselectureid":1429"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")