using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""courselectureid"":(\d+)";
string input = @"""1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4"",""metainfoid"":877,""courselectureid"":1429
""1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4"",""metainfoid"":877,""courselectureid"":1429
""1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4"",""metainfoid"":877,""courselectureid"":1429
""1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4"",""metainfoid"":877,""courselectureid"":1429
""1329/promovideo/file_01_Oct_2016_12_56_02_Promovideo.mp4"",""metainfoid"":877,""courselectureid"":1429";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}